Go Back   AC3D Forums > General > AC3D General
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 14th November 2022, 04:57 PM   #11
Andy
Administrator
Professional user
 
Andy's Avatar
 
Join Date: Jun 2003
Posts: 4,486
Default Re: V9 Front and Back Views Not working

Thanks. It appears to be a Mac only problem since it seems to look fine on my Windows laptop.


I'll have to try it on the Mac tomorrow.


From the pictures, it looks like there's some clipping going on. When you zoom in and out, do you see parts vanishing (being clipped)?
Andy is offline   Reply With Quote
Old 14th November 2022, 07:39 PM   #12
domhenry
Member
Advanced member
 
Join Date: Feb 2019
Posts: 48
Default Re: V9 Front and Back Views Not working

No seems to stay the same - just closer....
domhenry is offline   Reply With Quote
Old 15th November 2022, 09:20 AM   #13
Andy
Administrator
Professional user
 
Andy's Avatar
 
Join Date: Jun 2003
Posts: 4,486
Default Re: V9 Front and Back Views Not working

I can confirm this is Mac-only.


Very strange! It looks like there is some kind of clipping problem since if you 200% the part a few times, it looks fine.


The quick fix for this is to move the "top dip" cone object beneath the top section in the hierarchy. Then it seems to look fine. Please try this and let me know, if it fixes it for you.


It would be easy to blame this on the Mac implementation of OpenGL but at the moment, I can't rule out a bug in AC3D. The code is the same, so it should work the same on Windows AND Mac. I'm really not sure but I'll keep thinking about it...
Andy is offline   Reply With Quote
Old 16th November 2022, 01:38 AM   #14
domhenry
Member
Advanced member
 
Join Date: Feb 2019
Posts: 48
Default Re: V9 Front and Back Views Not working

The quick fix worked fine - thing is there are lots of these things about so it's not really a fix. It's still is absolutely fine in 8.6..... so I suppose OpenGL is not the answer....

Here is a single part that has the problem - ok in side / top / 3d - no good in front / back....

https://www.mediafire.com/file/ew348...rPart.zip/file

Dom
domhenry is offline   Reply With Quote
Old 16th November 2022, 05:47 AM   #15
Andy
Administrator
Professional user
 
Andy's Avatar
 
Join Date: Jun 2003
Posts: 4,486
Default Re: V9 Front and Back Views Not working

Unfortunately, the problem is the same in all 2D views. If you rotate the object, you can see it in the other windows. The 3D view works very differently. It appears that the clipping range is less on the Mac. Will keep investigating...
Andy is offline   Reply With Quote
Old 16th November 2022, 06:36 AM   #16
Andy
Administrator
Professional user
 
Andy's Avatar
 
Join Date: Jun 2003
Posts: 4,486
Default Re: V9 Front and Back Views Not working

Please try using this file (replace the old file with this):

You will need to open up the AC3D app bundle.

Put it in ac3dmac/AC3D.app/Contents/tcl
Attached Files
File Type: tcl ac3dview.tcl (39.5 KB, 4 views)
Andy is offline   Reply With Quote
Old 16th November 2022, 08:20 PM   #17
domhenry
Member
Advanced member
 
Join Date: Feb 2019
Posts: 48
Default Re: V9 Front and Back Views Not working

You cracked it Andy - well done and thanks
domhenry is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 03:33 AM.


AC3D Forum
(C) Inivis Limited 2020