Go Back   AC3D Forums > Technical > AC3D Bugs and Problems
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 1st March 2017, 08:40 AM   #1
Andy
Administrator
Professional user
 
Andy's Avatar
 
Join Date: Jun 2003
Posts: 4,381
Default Running AC3D 8 on Linux

"ac3d" is a 32 bit dynamically linked binary program and requires external libraries to have been installed

DEPENDING ON THE VERSION OF LINUX YOU ARE USING, YOU MAY REQUIRE EXTRA LIBRARIES IN ORDER TO RUN THIS PROGRAM

To get AC3D running on 64 bit Linux, start by installing these packages (example from Ubuntu Linux - others may use different methods of package installation)

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386
sudo apt-get install libxmu6:i386
sudo apt-get install libfreetype6:i386
sudo apt-get install libstdc++6:i386

check "ldd ./ac3d" to see what libraries are needed.

To add OpenGL:
sudo apt-get install --reinstall libgl1-mesa-glx:i386
sudo apt-get install libglu1-mesa:i386

others:
sudo apt-get install libjpeg62:i386
sudo apt-get install libtiff5:i386
sudo apt-get install libxft2:i386


All Linux system vary - please post your feedback (and Linux system) here.
Andy is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 10:05 PM.


AC3D Forum
(C) Inivis Limited 2020