Go Back   AC3D Forums > General > AC3D General
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 23rd April 2008, 12:28 AM   #21
Severa
Member
Advanced member
 
Join Date: Aug 2007
Posts: 41
Default Re: Sculptie Extrusion messing up UV Map

This has been tough for me too. If you use that sculpty extrude button it seems to fail most of the time. Sometimes it does work though. It seems like if I use it from the start and use that program sculptyspace you can open them in that to see if it even worked without bothering loading them up into SL first. Just do a search for that program and try things in there first. You can import the sculpted prim map and put a texture on it too. It's really useful for trial and error.
Severa is offline   Reply With Quote
Old 23rd April 2008, 01:29 AM   #22
lisa
Senior Member
Professional user
 
lisa's Avatar
 
Join Date: Mar 2005
Location: Phoenix, AZ
Posts: 917
Default Re: Sculptie Extrusion messing up UV Map

I understand your frustration; I know uv mapping is hard to learn. I'll have to mull it over a bit, but if I can come up with a good auto-mapping algo I'll update the plug-in to include it.

FYI: I don't work for Inivis, and I don't get paid in real dollars nor Linden dollars for any of this. I wrote the sculpty plug-in for my own ease-of-use and thought it might be nice to share. Andy was so kind as to incorporate it into the AC3D distro and help to support it and the community, which I think is awfully gracious of him.

I try to help the AC3D community specifically because I do understand your frustration. I work in 3D for a living, and it took me many years to learn these "technical" things that you insist that artists shouldn't have to know. (I have to laugh a little at this one, no offense meant, because the art leads of the studio where I work went with me to Los Angeles just last week for some hardcore hardware and software design instruction. Art makes or breaks frame-rate way faster than code. ) That said, if I can help someone else avoid having to jump through the same hoops, then I'm all for it.

I do honestly want to make this easier for new users, and I am listening to your concerns. I have a couple of fixes to some other plug-ins that are on my to-do list first, but again, if I can think of a good way to make it easier without breaking existing functionality--or perhaps as a separate piece if it can't be done within the context of what's there--then I'm happy to add it.

Incidentally, *specific* wishes and criticisms are much more useful to improving the software. i.e. "I wish I had a tool that did XYZ function" is much more helpful than "Aieeee, it didn't work." Obviously, if it wasn't working for me the way it was, I wouldn't have written it that way, lol. I can only guess at the way other people use it unless you show me.
lisa is offline   Reply With Quote
Old 23rd April 2008, 01:32 AM   #23
lisa
Senior Member
Professional user
 
lisa's Avatar
 
Join Date: Mar 2005
Location: Phoenix, AZ
Posts: 917
Default Re: Sculptie Extrusion messing up UV Map

Quote:
Originally Posted by Severa View Post
If you use that sculpty extrude button it seems to fail most of the time. Sometimes it does work though.
Do you have a specific case where you can repro this? It sounds like a bug.

The sculpy extrude function is actually one I've had some help on, so knowing how to reproduce the problem will go a long way toward fixing it.
lisa is offline   Reply With Quote
Old 24th April 2008, 05:53 PM   #24
Severa
Member
Advanced member
 
Join Date: Aug 2007
Posts: 41
Default Re: Sculptie Extrusion messing up UV Map

Well as a test I was making a pillar which you know about, and I had done the extrude, everything looked fine and I can always tell from the maps if they are going to fail. I did another and everything still looked good. It loaded up nicely in max and maya as well as zbrush, but in the viewer it looked all crazy - the extreme stretch. I'll mess with it later again and try to do something else to get a better explanation of what's going on with it.

Actually after posting this I just went back to messing with the TCE but I wanted to try an extrude for two eyes that protrude, it did it in that instance on one eye but not the other. I should have saved it but next time I see this happen, I'll post up a broken one so you can load it up yourself and see what's going on.

Last edited by Severa; 24th April 2008 at 05:55 PM.
Severa is offline   Reply With Quote
Old 7th May 2008, 05:18 AM   #25
Dania Daviau
Junior Member
Junior member
 
Join Date: May 2008
Posts: 3
Default Re: Sculptie Extrusion messing up UV Map

I am pretty sure the reason for your problem is same as I posted in AC3D Tutorials and How-To's , asking for exact definitions. Anyway for a sculptie you rather work with the dots and not the planes between them. A plane between dots in a sculptie is always flat by definition. I think there is the problem that most 3D programs work on a different definition than a sculpt. Making a sculpt is only approximative as I take it looking at the tools I get here. I recommend you to look at free sculptie programs to understand the definitions, like sculptypaints. If you use the logic after you understand the definition of the sculptie is then rather straightforward using AC3D. it gives nice results so far, though I would love if I had an exact reflection and not a aprrox. result. Sorry I am still new in normal 3D stuff, so I have problems to express me correctly. But I see that your planes are "bended" which would not result in a sculptie.
Dania Daviau is offline   Reply With Quote
Old 7th May 2008, 02:58 PM   #26
Severa
Member
Advanced member
 
Join Date: Aug 2007
Posts: 41
Default Re: Sculptie Extrusion messing up UV Map

Actually I may have fixed that problem. Nothing was off or clipping oddly, it just needed to be flipped. Doing that, it seems to be working now.
Severa is offline   Reply With Quote
Old 18th May 2008, 05:30 PM   #27
Severa
Member
Advanced member
 
Join Date: Aug 2007
Posts: 41
Default Re: Sculptie Extrusion messing up UV Map

Actually this extrude still haunts me. I extrude the end and the map is messed up in the TCE. I visually seem to be correcting it in the TCE and I know now how it should look. yet it is still not working on a simple extrusion. It'll usually be two sides. I'll correct one side and then move the verticles in the same way I did on the side I corrected, as it looks exactly the same, but the map blacks out in that area yet everything in the TCE looks clean. This is the most frustrating problem I've been having.
Severa is offline   Reply With Quote
Old 19th May 2008, 08:56 PM   #28
lisa
Senior Member
Professional user
 
lisa's Avatar
 
Join Date: Mar 2005
Location: Phoenix, AZ
Posts: 917
Default Re: Sculptie Extrusion messing up UV Map

Still working on a new version of the exporter, but here's a WIP of something complex made with it. I haven't been able to make it totally "mapless" but I do have a "precision" mode working that handles per-vertex maps.

It's not quite ready for primetime yet, a few bugs to work out still, but progress is being made.
Attached Thumbnails
Click image for larger version

Name:	Snapshot_038.jpg
Views:	226
Size:	611.5 KB
ID:	984  

lisa is offline   Reply With Quote
Old 22nd May 2008, 05:50 PM   #29
Severa
Member
Advanced member
 
Join Date: Aug 2007
Posts: 41
Default Re: Sculptie Extrusion messing up UV Map

Can't wait Lisa, I'm really looking forward to using it and it sounds like it will fix a lot of issues I'm personally having.
Severa is offline   Reply With Quote
Old 25th July 2008, 01:31 AM   #30
virtualalias
Member
Expert member
 
virtualalias's Avatar
 
Join Date: Jun 2008
Posts: 67
Default Re: Sculptie Extrusion messing up UV Map

This may or may not be the proper place for me to say this. But, since the issues of the Sculptie plug-ins are being brought up, I thought it relevant for me to mention that AC3D's Second Life Sculptie support is the sole reason I purchased the software.

So, yes...Perhaps it was gracious of the AC3D team to include your SL Sculptie Plug-In in their distribution channels...or maybe it was just good business. I think it is, perhaps, more of a value-add than some folks are giving it credit for.
virtualalias is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 02:20 AM.


AC3D Forum
(C) Inivis Limited 2020